CVE-2021-24490

The Email Artillery (MASS EMAIL) WordPress plugin through 4.1 does not properly check the uploaded files from the Import Emails feature, allowing arbitrary files to be uploaded. Furthermore, the plugin is also lacking any CSRF check, allowing such issue to be exploited via a CSRF attack as well. However, due to the presence of a .htaccess, denying access to everything in the folder the file is uploaded to, the malicious uploaded file will only be accessible on Web Servers such as Nginx/IIS
References
Configurations

Configuration 1 (hide)

cpe:2.3:a:email_artillery_project:email_artillery:*:*:*:*:*:wordpress:*:*

Information

Published : 2021-09-13 11:15

Updated : 2021-09-23 06:51


NVD link : CVE-2021-24490

Mitre link : CVE-2021-24490


JSON object : View

CWE
CWE-434

Unrestricted Upload of File with Dangerous Type

CWE-352

Cross-Site Request Forgery (CSRF)

Products Affected

email_artillery_project

  • email_artillery